• سلام به همه دوستان
    میخواستم بدونم که آیا نسخه پایتونی که باهاش ماژول رو نوشتیم و همه کارها شو کردیم با نسخه پایتونی که میخوایم باهاش ماژول رو نصب کنیم متفاوت باشه خطا میده.
    ممنون میشم اگه کمک کنید


  • سلام

    بستگی داره، اما باید تست کنید خب ببینید چه خطایی میده.
    ممکن هست ماژول رو مثلا با نسخه ۳.۸ نوشته باشید اما موقع اجرا با ۳.۷ خطا بده، اما برعکسش معمولا خطا نداره.


  • سلام. اگر کدهایی به کار برده باشین که در نسخه دیگه بروز رسانی نشده باشه، خب مسلماً مشکلی پیش نمیاد. اما اگر بخشی از کدهاتون در نسخه متفاوت، بروزرسانی شده باشه و متفاوت باشه، قطعا به مشکل میخورید.

    بهترین راه اینه که از همون ورژن استفاده کنید؛ و یا اگر از مجبور به استفاده از نسخه دیگه ای هستین باید کدهاتون رو با همون نسخه مطابقت بدین…